Поиск...

среда, 25 мая 2011 г.

Настраиваем статическую маршрутизацию на cisco router


Доброго времени суток!!!


В прошлом посте мы научились делать начальные настройки на роутере cisco. Сегодня, я предлагаю вам настроить статическую маршрутизацию на нескольких устройствах.
Всем, кому интересно, приглашаю под кат…

Для моделирования устройств и схемы я буду использовать все тот же GNS3.
Вот такую схему мы будем реализовывать:



Итоговой проверкой будет наличие пингов с конечных хостов между собой :). Итак, начнем настройку.
Настраиваем роутер R1 в сторону хоста (интерфейс Fa 0/0):
  • R1>
  • R1>en
  • R1#conf t
  • R1(config)#int fa 0/0
  • R1(config-if)#description Link_to_host
  • R1(config-if)#ip address 172.16.10.1 255.255.255.0
  • R1(config-if)#no sh
  • R1(config-if)#exit
  • R1(config)#
Теперь настроим роутер в сторону R2 (интерфейс Ser 0/0/0):
  • R1(config)#int serial 0/0
  • R1(config-if)#description Link_to_R2
  • R1(config-if)#clock rate 56000
  • R1(config-if)#ip address 172.16.20.1 255.255.255.252
  • R1(config-if)#no sh
  • R1(config-if)#exit
  • R1(config)#exit
  • R1#wr
Сделаем такие же настройки на роутерах R2 и R3, только с соответствующей IP – адресацией:
  • R2>en
  • R2#conf t
  • R2(config)#int fa 0/0
  • R2(config-if)#description Link_to_host
  • R2(config-if)#ip address 172.16.30.1 255.255.255.0
  • R2(config-if)#no sh
  • R2(config-if)#exit
  • R2(config)#
  • R2(config)#int serial 0/0
  • R2(config-if)#clock rate 56000
  • R2(config-if)#ip address 172.16.20.2 255.255.255.252
  • R2(config-if)#no sh
  • R2(config-if)#description Link_to_R1
  • R2(config-if)#exit
  • R2(config)#int serial 0/1
  • R2(config-if)#clock rate 56000
  • R2(config-if)#ip address 172.16.40.1 255.255.255.252
  • R2(config-if)#no sh
  • R2(config-if)#description Link_to_R3
  • R2(config-if)#exit
  • R2(config)#exit
  • R2#wr
  • R3>
  • R3>en
  • R3#conf t
  • R3(config)#int fa 0/0
  • R3(config-if)#description Link_to_host
  • R3(config-if)#ip address 172.16.50.1 255.255.255.0
  • R3(config-if)#no sh
  • R3(config-if)#exit
  • R3(config)#int serial 0/1
  • R3(config-if)#description Link_to_R2
  • R3(config-if)#clock rate 56000
  • R3(config-if)#ip address 172.16.40.2 255.255.255.252
  • R3(config-if)#no sh
  • R3(config-if)#exit
  • R3(config)#exit
  • R3#wr
Протестируем сетевую доступность между роутерами и посмотрим на таблицу маршрутизации:




Проверим доступность роутеров с конечных хостов и убедимся, что на данный момент связи между этими хостами нет:




Как видим, доступность роутеров присутствует, но дальше трафик не проходит. Давайте это исправим.
Добавим соответствующие статические маршруты на наши роутеры.
Заходим на роутер R1 и добавляем в конфигурацию следующее:
  • R1>en
  • R1#conf t
  • R1(config)#ip route 172.16.30.0 255.255.255.0 172.16.20.2
  • R1(config)#ip route 172.16.40.0 255.255.255.252 172.16.20.2
  • R1(config)#ip route 172.16.50.0 255.255.255.0 172.16.20.2
  • R1(config)#exit
  • R1#
На других роутерах делаем аналогичные действия:
  • R2>en
  • R2#conf t
  • R2(config)#ip route 172.16.10.0 255.255.255.0 serial 0/0
  • R2(config)#ip route 172.16.50.0 255.255.255.0 serial 0/1
  • R2(config)#exit
  • R2#wr
  • R3>en
  • R3#conf t
  • R3(config)#ip route 0.0.0.0 0.0.0.0 serial 0/1
  • R3(config)#exit
  • R3#wr
Обратите внимание, что на каждом роутере мы прописывали маршруты по-разному.
В первом случае, мы добавляли маршруты в конкретные сети и прописывали IP – адрес соседа, в качестве next-hop.
Во втором случае, мы прописывали маршруты, указывая, что соответствующий трафик следует отправлять через соответствующие интерфейсы.
В третьем случае, мы добавили так называемый default route, согласно которому, весь неизвестный трафик (место назначения которого, нет в таблице маршрутизации) отправлять через соответствующий интерфейс.
Как видно, добавлять статические маршруты можно разными способами :).
Теперь давайте проверим сетевую доступность между конечными хостами:




Как видно на картинках, у нас все получилось. Поздравляю вас!!!! Мы настроили статическую маршрутизацию на наших роутерах :). Для самостоятельного изучения маршрутизации советую вам изучить курс Cisco Routing and Switching.

На этом я хочу закончить этот пост. Надеюсь, мой пост был интересен и полезен.

Пишите коменты, задавайте вопросы, высказывайте пожелания. С радостью отвечу всем.

Жду вас в следующих постах!!!
С уважением, Ant0ni0n.

Компания "Меркатос" предлагает маршрутизатор Cisco 2921. Звоните!

50 комментариев:

  1. Огромное спасибо за уроки!!!Очень мне пригодилось....да же если НУЛЬ в этом большой...ТО теперь я представляю что такое cisco и с чем его едят....
    А теперь по вопросом:
    Я вот проходил все настройки по Вашим урока и вот запнулся на этом уроке.
    Я вот не могу соединить "R1(config)#int serial 0/0"т.е. пишу команду а у меня помечает маркером что команда не правильна "serial"
    В чем беда не пойму...
    Может проблема в соединение R1-R2-R3 на физическом уровне...т.е. настройках порта я не сделал? Подскажи как и где это сделать?Всю прогу облазил нечего не нашел!

    ОтветитьУдалить
  2. Спасибо за отзыв, очень приятно :)
    По вашему вопросу могу ответить следующее:
    - посмотрите в свойствах роутера (правой клавишей по устройству) есть ли serial интерфейсы,
    - проверьте командой show ip interface brief есть вообще в наличии интерфейсы serial в конфиге,
    - скажите пожалуйста, роутеры какой серии вы используете...
    Пока только эти рекомендации могу дать... Если не поможет, то могу выслать вам потом файл *.net с конфигами роутеров, может это поможет. Но это я смогу сделать только в пн, так как пока нахожусь в отпуске :)

    ОтветитьУдалить
  3. 1.IOS 3745
    2.Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 unassigned YES NVRAM administratively down down
    FastEthernet0/1 unassigned YES NVRAM administratively down down
    FastEthernet1/0 unassigned YES NVRAM administratively down down
    FastEthernet3/0 unassigned YES unset administratively down down
    FastEthernet3/1 unassigned YES unset administratively down down
    FastEthernet3/2 unassigned YES unset administratively down down
    FastEthernet3/3 unassigned YES unset administratively down down
    FastEthernet3/4 unassigned YES unset administratively down down
    FastEthernet3/5 unassigned YES unset administratively down down
    FastEthernet3/6 unassigned YES unset administratively down down
    FastEthernet3/7 unassigned YES unset administratively down down
    FastEthernet3/8 unassigned YES unset administratively down down
    FastEthernet3/9 unassigned YES unset administratively down down
    FastEthernet3/10 unassigned YES unset administratively down down
    FastEthernet3/11 unassigned YES unset administratively down down
    FastEthernet3/12 unassigned YES unset administratively down down
    FastEthernet3/13 unassigned YES unset administratively down down
    FastEthernet3/14 unassigned YES unset administratively down down
    FastEthernet3/15 unassigned YES unset administratively down down
    Vlan1 unassigned YES unset administratively down down
    Я тут вижу что его нет.
    3.Нажимаю правой кнопкой и вываливается список там я не нахожу свойства,есть только настроить.
    Вы извините я просто только только начал изучать....Хочу изучить и научиться настраивать cisco....Ваш сайт в этом мне очень помогает...
    спасибо вам=)

    ОтветитьУдалить
  4. можно скинуть мне на мыло grom_27@mail.ru

    ОтветитьУдалить
  5. Да, интерфейсов serial у вас нет. Можете тогда соединить роутеры через интерфейсы fastethernet 0/0, 0/1, 1/0 и настроить их. Настройка будет такая же как и для serial, только без команды clock rate.
    А как настраивать устройство через правую клавишу, можете почитать вот тут http://go-to-easyit.blogspot.com/2011/04/gns3.html
    Там посмотрите про закладку Slots.
    Ну а сбросить файл с конфигами роутеров смогу только в пн.

    ОтветитьУдалить
  6. ок спасибо....жду файла..=)

    ОтветитьУдалить
  7. Хорошая статья, для полной картины не хватает описания clock rate, зачем оно, откуда и куда.

    ОтветитьУдалить
    Ответы
    1. Спасибо за отзыв!!!
      Clock rate - это тактовая частота (частота синхронизации). Она настраивается на serial интерфейсах, так они требуют наличия синхронизации. Специфика сетей WAN.
      Подробнее можно почитать вот тут:http://www.netconfig.org/routing/587. Присутствие clock rate в настройках обусловлено всего лишь использованием serial интерфейсов. Если бы были ethernet интерфейсы, этого бы не было :).

      С уважением, Ant0ni0n

      Удалить
  8. И вот я разобрался что такое clock rate. И нашел ошибку в статье. Устанавливать clock rate нужно только с одной стороны с которой DCE, для DTE оно не нужно. Поэтому либо для R2 с двух сторон на выходе DCE и ставим на оба clock rate, либо на R1 и R3, а на R2 вообще не ставим.

    ОтветитьУдалить
  9. О, и в тут http://www.netconfig.org/routing/587 про это тоже написано :).

    ОтветитьУдалить
  10. Ant0ni0n, а вот если бы были ethernet интерфейсы, то при первой отправке пакет не доходит, а при второй доходит. Если проследить сниффером, то оказывается что сначала не существует данных в ARP таблице, а далее он отправляет запрос и обновляет ARP таблицу. Это нормальная практика, или есть способ что бы сразу доходили пакеты. И я правильно понял, что для ethernen Routing таблица не нужна?

    ОтветитьУдалить
    Ответы
    1. Ну от ARP вы не избавитесь никогда, так как это логика работы сети. Просто когда появляется новый комп в сети, он автоматом рассылает ARP запросы, чтобы знать, куда и кому отправлять пакеты.
      Грубо говоря, он задает вопрос:"Кто имеет такой то IP-адрес" и ждет ответа, чтобы потом поставить в заголовок пакета ethernet нужный mac-address...
      Без этого никуда. И потом в процессе с определенным периодом он обновляет таблицу...
      И немного не понял последнего вопроса... Что значит для ethernet Routing таблица не нужна..

      Удалить
    2. Ой, не пакета, а ethernet - фрейма :)

      Удалить
    3. Насчет clock rate вы правы, ставить его достаточно с одной стороны, но в GNS3 он вобще включен на интерфейсах serial по умолчанию, я их просто добавил в конфиг, на случай, если кто-то будет делать настройки на реальном оборудовании.
      Так сказать, чтобы не забыли :)

      Удалить
  11. Да, что-то с serial интерфейс не проходит, выдает ощибку:
    R3(config)#int serial 0/0
    ^
    % Invalid input detected at '^' marker.

    Пробовал профили С2600, С3745, С 2600 - типа нет сериалов

    ОтветитьУдалить
    Ответы
    1. Ну я тут использовал 3745 (c3745-advipservicesk9-mz[1].124-15.T6.bin), все вроде есть и работает...
      Попробуйте кликнуть (до запуска роутера) правой улавишей на нем, затем configure. Там пройдите во вкладку Slots. Снизу вы должны видеть ваши serial интерфейсы (у меня их три штуки) и нажмите затем "Apply".
      Если вдруг их нет, то посмотрите в выпадающем меню в параметрах "WICs", там они должны быть. После добавления снова нажмите "Apply".

      С уважением, Ant0ni0n

      Удалить
  12. Спасибо за блог, продолжайте, очень познавательно.
    пользую c3745-a3jk9s-mz.123-4.T2.bin, помогло в configure нажатие Apply, спасибо.
    Что скажете по clock rate, сообщение от 1.02 Crispy

    ОтветитьУдалить
    Ответы
    1. Рад, что помог!!! Заходите еще :)

      Насчет clock rate вроде пояснил :) Если еще вопросы будут, пишите, будем разбираться вместе :)

      Удалить
  13. почему на R2 маршрут 10-й сети при написании "serial 0/0" работает, если прописать - ip route 172.16.10.0 255.255.255.0 172.16.20.2 выдает ошибку %Invalid next hop address (it's this router).
    172.16.20.2 это же и есть serial 0/0 на R2 ?

    ОтветитьУдалить
    Ответы
    1. Так как так нельзя делать. Когда вы пишете serial интерфейс, то это физическое соответствие (т.е. через этот физический интерфейс отправлять пакеты, адресованные заданной сети). А когда вы прописываете IP-адрес, то это уже L3 уровень (маршрутизация). При прописывании в качестве next-hop IP адреса, адрес должен быть соседнего устройства (того, за которым достижима указанная сеть в дальнейшем).
      Здесь же вы указали, что следующий hop это он сам, а так нельзя :)

      Удалить
    2. ну, или проще: Ваш шлюз 172.16.20.2 - это другая подсеть относительно 172.16.10.0\24. Вот он и ругается.

      Удалить
  14. понял, спасибо.

    ОтветитьУдалить
  15. При попытке пинга маршрутизатора от хоста появляется сообщение:

    PING 172.16.10.1 (172.16.10.1): 56 data bytes
    ping: sento: Network is unreachable

    Подскажите pls, почему сеть недоступна?

    ОтветитьУдалить
  16. Предполагаю, нужно прописать на интерфейсе хоста ip из данной подсети. т.к при включении dhcp пинги проходят. Как это сделать в qemu?

    ОтветитьУдалить
    Ответы
    1. Да, конечно!!! Ip адрес нужно прописывать обязательно!!
      Если у вас Tinycore, то там в нижнем меню есть пункт "Panel", там в открывшемся окне есть пункт "Network", в ней и настраиваются параметры сети.
      Если использовать командную строку, то надо ее открыть в нижнем меню "Aterm" и прописать следующие команды:
      tc@box:~$ sudo su
      root@box:~$ ifconfig eth0 172.16.10.10 netmask 255.255.255.0 up
      root@box:~$ route add default gw 172.16.10.1

      После этого все должно работать :)

      Удалить
  17. Подскажите по Cisco Packet tracer. и DNS
    в сети имеем 2 днс сервера. днс1 не хранит у себя явных адресных записей. Адресные записи хранятся на сервере днс2. В первом пробовал * и *.* направить на ип днс2. не помогло . куда копать?

    ОтветитьУдалить
    Ответы
    1. Доброго времени суток!
      Ну по Cisco Packet tracer сказать сразу не смогу, так как пользовался им уже очень давно. Но по вопросу, если хотите, то пришлите мне схему и конфигурацию устройств на почту, посмотрим что у вас не так.

      Удалить
  18. Кому интересно, чтобы появился Serial интерфейс надо в свойствах в свободном слоте добавить NM-4T. Это дает 4 serial интерфейса. (1/0, 1/1, 1/2, 1/3).

    ОтветитьУдалить
  19. Спасибо большое...очень доступно написано...помогло в подготовке к проекту...буду читать дальше)

    ОтветитьУдалить
  20. подскажите пожалуйста, есть сеть,на роутер подает провайдер L2, как мне прописать на этот интерфейс подсети, которые нужно передать в этот интерфейс?

    ОтветитьУдалить
  21. Здравствуйте,у меня такой вопрос: У вас есть 3 хоста, и вы делаете пинг из одного к другому через программу Терминал, как вы определяете с какого хоста идет пинг, я так понимаю вы добавили 3 адаптера замыкания на себя. Я когда пытаюсь пингануть, он пингует сам себя, трассировка никуда не выходит.

    ОтветитьУдалить
    Ответы
    1. Добрый день!!!
      Нет, это не адаптеры замыкания "сам на себя". Если вы посмотрите на схему, то заметите, что это 3 отдельные QEMU-host-а. Это мини образы линукса, которые можно подключить к GNS3. Соответственно они имеют по одной сетевой карте, каждая в своей сети.

      Удалить
  22. А можно немного пояснить как работает ARP протокол на Serial интерфейсах в случае, когда вместо next hop указано имя исходящего serial интерфейса?
    Знаю, что если на обычных Ethernet интерфейсах так прописать, то на соседнем маршрутизаторе должен быть включен proxy arp, но тогда на первом маршрутизаторе будет огромная таблица маршрутов для каждого адреса как directly connected, и таблица ARP тоже будет содержать записи кучи адресов с одинаковым mac-адресом (интерфейса соседнего маршрутизатора). А как serial интерфейсы ведут себя в таких случаях? Если можно, объясните подробнее алгоритм передачи кадра :)

    ОтветитьУдалить
    Ответы
    1. Прочитал про HDLC и PPP, понял что никакого ARP на serail нет, работает по-другому :) Тогда возник другой вопрос, как используются ip-адреса на serial-интерфейсах при статической маршрутизации?

      Удалить
    2. Serial - тип интерфейса. Всё зависит от того, какой канальный протокол будете использовать поверх него. В FR, например, есть Inverse ARP.
      Использовать, например, в случае соединений точка-многоточка. Либо для того, чтобы проверять доступность соседа, например. Либо когда NATят в него. Вариантов много. ;-)

      Удалить
  23. Спасибо за статью, все доступно и понятно!

    ОтветитьУдалить
  24. Спасибо большое за данную статью!
    Не могли бы вы подсказать, почему у меня не получается пропинговать с PC1 на PC2 или PC3 ?

    ОтветитьУдалить
  25. Здравствуйте,такой вопрос, не подскажите как настроить алгоритм WRED?
    Был бы очень признателен.

    ОтветитьУдалить
  26. Вы пишете маску для конечного узда 255.255.255.0
    Но у меня при вводе IP 172.16.10.0 разрешает только 255.255.0.0

    ОтветитьУдалить
  27. Спс. Действительно работает все на ура.

    ОтветитьУдалить
  28. Добрый вечер ! Пытаюсь на реальном оборудовании настроить маршрутизацию ( компьютер, далее 3 порт cisco 851, далее модем adsl далее провайдер.) Так вот, с cisco я и модем пингую, и сайты типа гугла в интернете, а с компьютера достукиваюсь только до cisco? а на модем и дальше выйти не могу. Где копать ?
    Вот листинг настроек :
    Building configuration...

    Current configuration : 884 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname router851
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$q/Am$twstMO0H2FWM.7EJ0yRhz1
    enable password cisco1
    !
    no aaa new-model
    !
    resource policy
    !
    ip subnet-zero
    !
    !
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    shutdown
    !
    interface FastEthernet2
    shutdown
    !
    interface FastEthernet3
    shutdown
    !
    interface FastEthernet4
    ip address 192.168.1.6 255.255.255.0
    duplex auto
    speed auto
    !
    interface Vlan1
    ip address 10.19.1.2 255.255.255.0
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    no ip http server
    no ip http secure-server
    !
    snmp-server community cisco RO
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    password cisco
    login
    !
    scheduler max-task-time 5000
    end

    ОтветитьУдалить
  29. Добрый день. Почему нельзя пинговать маршрутизаторы между собой?

    ОтветитьУдалить
    Ответы
    1. Потому что не заданы айпишники самих роутеров. Для этого нужно их прописать.

      Удалить
  30. Большое спасибо! Очень полезная инфа для новичка сисадмина!

    ОтветитьУдалить
  31. Всем добрый день. Помогите плиз. Какой командой можно просмотреть ТОЛЬКО статические маршруты в таблице маршрутизации Cisco?
    PS: команда sh ip route на подходит.

    ОтветитьУдалить
  32. Ебал я в рот ваш cisco

    ОтветитьУдалить
  33. Бубенцова здарова

    ОтветитьУдалить