Поиск...

среда, 1 июня 2011 г.

Настройка EIGRP на cisco

Доброго времени суток!!!


В прошлом посте я рассказывал, как настроить протокол динамической маршрутизации RIP на роутерах cisco. Сегодня я предлагаю вам познакомиться с настройкой IEGRP на роутерах cisco.
Кому интересно, милости прошу под кат…

Как и в прошлый раз, не будем останавливаться на теории. Она есть в превеликом достатке в интернете.

Перейдем сразу к настройкам.
В качестве среды для реализации схемы и настроек, я буду использовать все тот же GNS3.
Вот такую схему мы будем реализовывать:



Для обеспечения сетевой доступности между хостами будем использовать сети из диапазона 172.16.х.0/24 и еще сделаем дополнительный маршрут по умолчанию (0.0.0.0 0.0.0.0 через 192.168.0.2/24). Успешной реализацией схемы будем считать наличие ping-ов между хостами и «внешнего» IP-адреса маршрута по умолчанию.
Дополнительно, настроим работу EIGRP с использованием аутентификации, может кому-нибудь пригодится :).
Итак, приступим к настройкам. Заходим на первый роутер и делаем следующие настройки:
  • R1>en
  • R1#conf t
  • R1(config)#hostname Router_1
  • Router_1(config)#interface serial 0/0 – заходим в настройки интерфейса
  • Router_1(config-if)#ip address 172.16.20.1 255.255.255.0 – назначаем IP - адрес
  • Router_1(config-if)#clock rate 56000
  • Router_1(config-if)#description To_Router_2
  • Router_1(config-if)#ip authentication mode eigrp 100 md5 – включаем аутентификацию MD5 пакетов EIGRP
  • Router_1(config-if)#ip authentication key-chain eigrp 100 test – назначаем ключевую последовательность «test» для аутентификации
  • Router_1(config-if)#no shutdown
  • Router_1(config-if)#interface fa 0/0
  • Router_1(config-if)#ip address 172.16.10.1 255.255.255.0
  • Router_1(config-if)#description To_host
  • Router_1(config-if)#no shutdown
  • Router_1(config-if)#exit
  • Router_1(config)#router eigrp 100 – заходим в настройки EIGRP
  • Router_1(config-router)#no auto-summary – выключаем автосуммаризацию (если она включена)
  • Router_1(config-router)#eigrp log-neighbor-changes – включаем отображение изменений в консоли между соседними роутерами EIGRP
  • Router_1(config-router)#network 172.16.0.0
  • Router_1(config-router)#exit
  • Router_1(config)#key chain test – настраиваем ключевую последовательность для аутентификации
  • Router_1(config-keychain)#key 1
  • Router_1(config-keychain-key)#key-string cisco – назначаем ключевое слово
  • Router_1(config-keychain-key)#exit
  • Router_1(config-keychain)#exit
  • Router_1(config)#exit
  • Router_1#wr
  • Router_1#
Заходим на второй роутер и делаем аналогичные настройки:
  • R2>
  • R2>en
  • R2#conf t
  • R2(config)#hostname Router_2
  • Router_2(config)#int serial 0/0
  • Router_2(config-if)#ip address 172.16.20.2 255.255.255.0
  • Router_2(config-if)#clock rate 56000
  • Router_2(config-if)#description To_Router_1
  • Router_2(config-if)#ip authentication mode eigrp 100 md5
  • Router_2(config-if)#ip authentication key-chain eigrp 100 fortest
  • Router_2(config-if)#no shutdown
  • Router_2(config-if)#exit
  • Router_2(config)#interface fa 0/0
  • Router_2(config-if)#ip address 172.16.30.1 255.255.255.0
  • Router_2(config-if)#no sh
  • Router_2(config-if)#no shutdown
  • Router_2(config-if)#exit
  • Router_2(config)#router eigrp 100
  • Router_2(config-router)#no auto-summary
  • Router_2(config-router)#eigrp log-neighbor-changes
  • Router_2(config-router)#network 172.16.0.0
  • Router_2(config-router)#exit
  • Router_2(config)#key chain fortest
  • Router_2(config-keychain)#key 1
  • Router_2(config-keychain-key)#key-string cisco
  • Router_2(config-keychain-key)#exit
  • Router_2(config-keychain)#exit
  • *Mar 1 00:39:07.875: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.16.20.1 (Serial0/0) is up: new adjacency – данное сообщение свидетельствует о том, что наши роутеры договорились и процесс EIGRP с аутентификацией успешно работает
  • Router_2(config-keychain)#exit
  • Router_2(config)#int fa 0/1
  • Router_2(config-if)#ip address 192.168.0.1 255.255.255.0
  • Router_2(config-if)#no sh
  • Router_2(config-if)#exit
  • Router_2(config)#exit
  • Router_2#wr
  • Router_2#
Итак, настройки сделаны, теперь давайте проверим, что у нас получилось. Посмотрим таблицу маршрутизации на роутерах, проверим настройку EIGRP командами show, проверим сетевую доступность между хостами:







Как видно, все у нас получилось, маршруты присутствуют, роутеры дружат :), хосты пингуются :).
Единственное, чего пока еще нет, это маршрута по умолчанию, и, следовательно, отсутствие ping на «внешний» адрес (192.168.0.2). Давайте, это исправим :).
Заходим на второй роутер и добавляем следующие настройки:
  • Router_2#
  • Router_2#conf t
  • Router_2(config)#ip route 0.0.0.0 0.0.0.0 192.168.0.2
  • Router_2(config)#router eigrp 100
  • Router_2(config-router)#redistribute static
  • Router_2(config-router)#exit
  • Router_2(config)#exit
  • Router_2#
Этими командами мы, сначала, добавили статический маршрут по умолчанию, а затем сделали редистрибуцию его в EIGRP. Теперь об этом маршруте будут знать все роутеры, участвующие в процессе EIGRP (в нашем случае только один :)). Давайте проверим это.




Обратите внимание, что на первом роутере этот маршрут получен по EIGRP и является «external» (флаг D* EX), а на втором роутере (который анонсирует этот маршрут), он обозначается как статический маршрут по умолчанию (S*).
Теперь осталось проверить ping с конечных хостов на «внешний» IP – адрес:





Все получилось, сетевая доступность обеспечена :). Поздравляю вас!!!
Приведу вам еще команды, для более точной настройки EIGRP, вдруг пригодятся :):
  • Router(config-if)#bandwidth x – установка полосы пропускания, настраивается на интерфейсе и используется EIGRP в процессе вычисления метрики маршрута (не влияет на сам интерфейс);
  • Router(config-router)#metric weights tos k1 k2 k3 k4 k5 – меняет настройки коэффициентов для процесса вычисления метрики, заданные по умолчанию;
  • Router#show ip eigrp neighbors – показывает таблицу «соседей», участвующих в процессе EIGRP;
  • Router#show ip eigrp interfaces – показывает информацию по каждому интерфейсу, участвующему в EIGRP;
  • Router#show ip route eigrp – показывает таблицу маршрутизации только с маршрутами EIGRP;
Группа команд debug:
  • Router#debug eigrp fsm
  • Router#debug eigrp packet
  • Router#debug eigrp neighbor
  • Router#debug ip eigrp neighbor
  • Router#debug ip eigrp notifications
На этом я хочу закончить этот пост. В нем мы научились настраивать EIGRP с аутентификацией на роутерах cisco и немного затронули процесс редистрибуции статических маршрутов в EIGRP.
Надеюсь, вы узнали что-то новое, вспомнили уже знакомое, или вам было просто интересно :).

Пишите коменты, задавайте вопросы, высказывайте пожелания. С радостью отвечу всем.

Жду вас в следующих постах!!!
С уважением, Ant0ni0n.


6 комментариев:

  1. сделал все так же, только с R1 C1 не пингуеся!!!!

    ОтветитьУдалить
  2. Доброе утро :)
    Вопрос первый:
    Что находится у вас за C1 (ваша физическая машина, VMWare workstation) и как идет подключение (через loopback, Vmware Network adapter)?
    Вопрос второй:
    Прописывали ли вы маршрут к вашему R1 на этой машине (route add 172.16.20.0 mask 255.255.255.0 192.168.0.1 -p согласно рисунку например)? Так как если вы этого не делали, то весь ваш неизвестный трафик (а физическая машина не знает об этой сети), уходит по маршруту по умолчанию и не доходит до адресата.
    Напишите, если получится.

    С уважением, Ant0ni0n

    ОтветитьУдалить
  3. Спасибо Вам большое за статью!!!

    ОтветитьУдалить
  4. спасибо за пост )) у меня вопрос. Сколько хостов я могу добавить через Loopback adapter? только один? у меня bridge между atheros and loopback.

    ОтветитьУдалить
    Ответы
    1. Я думаю в стандартной ситуации - то один хост. А если вы поставите bridge или завернете (свяжете) его (loopback adapter) в VMWare Workstation или еще куда, где настроено несколько компьютеров в одной сети, то получится, что и больше одного.
      Как то так... :)

      Удалить