Поиск...

пятница, 27 мая 2011 г.

Настройка RIP на cisco в GNS3

Доброго времени суток!!!


В прошлом посте я рассказывал, как настроить статическую маршрутизацию на роутерах cisco в GNS3. Сегодня, я предлагаю настроить протокол динамической маршрутизации RIP. Сейчас он уже редко где применяется, но все же знать о нем необходимо :).
Заинтересовало? Тогда добро пожаловать под кат…

Теорию по этому протоколу можно найти в интернете в больших объемах (ссылка), так что останавливаться на этом не будем :).
Схема, которую мы будем реализовывать, выглядит так:



Положительным результатом будем считать наличие нужных маршрутов в таблице маршрутизации и Ping между хостами.
Начнем настройку. Запускаем наши роутеры, настраиваем интерфейсы и IP – адреса, согласно схеме.
  • Router_1>en
  • Router_1#conf t
  • Router_1(config)#int fa 0/0
  • Router_1(config-if)#ip address 172.16.10.1 255.255.255.0
  • Router_1(config-if)#description To_host
  • Router_1(config-if)#no sh
  • Router_1(config-if)#int ser 0/0
  • Router_1(config-if)#ip address 172.16.20.1 255.255.255.252
  • Router_1(config-if)#description To_Router_2
  • Router_1(config-if)#no sh
  • Router_1(config-if)#exit
  • Router_1(config)#^Z
  • Router_1#wr
  • R2>en
  • R2#conf t
  • R2(config)#hostname Router_2
  • Router_2(config)#int fa 0/0
  • Router_2(config-if)#ip address 172.16.30.1 255.255.255.0
  • Router_2(config-if)#description To_host
  • Router_2(config-if)#no sh
  • Router_2(config-if)#int ser 0/0
  • Router_2(config-if)#ip address 172.16.20.2 255.255.255.252
  • Router_2(config-if)#no sh
  • Router_2(config-if)#description To_Router_2
  • Router_2(config-if)#int ser 0/1
  • Router_2(config-if)#ip address 172.16.40.1 255.255.255.252
  • Router_2(config-if)#no sh
  • Router_2(config-if)#description To_Router_3
  • Router_2(config-if)#exit
  • Router_2(config)#^Z
  • Router_2#wr
  • R3>en
  • R3#conf t
  • R3(config)#hostname Router_3
  • Router_3(config)#int fa 0/0
  • Router_3(config-if)#ip address 172.16.50.1 255.255.255.0
  • Router_3(config-if)#no sh
  • Router_3(config-if)#description To_host
  • Router_3(config-if)#int ser 0/1
  • Router_3(config-if)#ip address 172.16.40.2 255.255.255.252
  • Router_3(config-if)#description To_Router_2
  • Router_3(config-if)#no sh
  • Router_3(config-if)#exit
  • Router_3(config)#^Z
  • Router_3#wr
Проверим сетевую доступность между роутерами:








Теперь, проверим доступность роутеров с конечных хостов и отсутствие (на данный момент) сетевой доступности между хостами.







Как видно, роутеры пингуются, а вот между хостами связи нет :). Давайте, это исправим.
Заходим по очереди на роутеры и делаем следующие настройки:
  • Router_1#conf t
  • Router_1(config)#router rip – заходим в режим настройки RIP
  • Router_1(config-router)#version 2 – выбираем версию 2
  • Router_1(config-router)#network 172.16.0.0 – добавляем сеть
  • Router_1(config-router)#no auto-summary - отключаем автосуммаризацию
  • Router_1(config-router)#exit
  • Router_1(config)#exit
  • Router_1#wr
  • Router_2#conf t
  • Router_2(config)#router rip
  • Router_2(config-router)#version 2
  • Router_2(config-router)#network 172.16.0.0
  • Router_2(config-router)#no auto-summary
  • Router_2(config-router)#exit
  • Router_2(config)#exit
  • Router_2#wr
  • Router_3#conf t
  • Router_3(config)#router rip
  • Router_3(config-router)#version 2
  • Router_3(config-router)#network 172.16.0.0
  • Router_3(config-router)#no auto-summary
  • Router_3(config-router)#exit
  • Router_3(config)#exit
  • Router_3#
Надо помнить, что добавление сетей в процесс RIP осуществляется заданием classful network, а не подсетью. То есть правильно 172.16.0.0, а не 172.16.10.0.
Все, должно работать :). Проверим таблицы маршрутизации и сетевую доступность между хостами.













Как видно из картинок, у нас все получилось. Поздравляю вас, протокол динамической маршрутизации RIP у нас заработал!!!
Для детальных настроек RIP существуют еще команды. Вот некоторые из них:
  • Router(config-router)#no network w.x.y.z – удаляет сеть из процесса PIR;
  • Router(config-router)#version 1 – включает RIP версии 1;
  • Router(config-router)#passive-interface s0/0/0 – выключает посылку обновлений RIP на заданном интерфейсе (по умолчанию, рассылка обновлений включается на всех интерфейсах);
  • Router(config-router)#timers basic <> - позволяет задавать таймеры обновлений, время отклика и так далее…;
  • Router#debug ip rip – отображает всю информацию о работе протокола RIP в реальном времени;
  • Router#show ip rip database – отображает содержимое базы данных ( информации о маршрутах);
На этом я хочу закончить этот пост. Надеюсь, он был интересен и полезен.


Пишите коменты, задавайте вопросы, высказывайте пожелания. С радостью отвечу всем.

Жду вас в следующих постах!!!
С уважением, Ant0ni0n.

18 комментариев:

  1. Добрый день!
    Что используется в качестве Qemu host?
    У меня linux-microcore-2.10.img, коосоль не стартует....(появляется и исчезает) :(

    ОтветитьУдалить
    Ответы
    1. используйте Tinycore linux, работает. проверенно! :)
      единственная особенность нельзя консоль его закрывать, только сворачивать. иначе придется рестартовать хост.

      Удалить
  2. На Win Vista этот же имидж не работает, при попытке вытянуть на панель топологии - "Ошибка Dynamips: 206-unable to create Qemu instance 'QEMU1' "
    Может другой имидж хоста посоветуете?

    ОтветитьУдалить
    Ответы
    1. Попробуйте запустить программу GNS от имени администратора, затем проверьте соответствие образа в настройках.
      А так, можете скачать Tinycore linux и настроить его.

      Удалить
  3. спасибо, забыл что Виста требует адм.прав.

    ОтветитьУдалить
  4. Intel Core Duo 2Ghz, 2Gb данная схема со всеми активными элементами не живет совсем :(
    dynamips-wxp.exe в диспетчере 98% загрузки, можно что-то еще оптимизировать?
    Idle PC коммутаторов настроил...

    ОтветитьУдалить
    Ответы
    1. Доброго времени суток!!!
      Ну у меня 4 ядра и оперативки 8 Гб. Тормозит у тебя так как тут используются Qemu хосты, которые тоже очень неплохо подгружают комп...
      Я бы посоветовал тебе заменить Qemu хосты loopback интерфейсами или роутерами. Здесь хосты используются только ради пинга.
      Или еще попробовать vpc (на сайте GNS он есть помойму), может он не так кушает ресурсы...

      Удалить
    2. выставить Idle PC со звездочкой (*), у меня обычно это 52, 58 и т.п.
      для корректного выставления и подсчета Idle PC необходимо включить роутер и подождать немного (2 минуты) и тогда GNS сможет правильно рассчитать Idle PC.
      как пример, на Core-i3 и 2GB RAM Win7 32bit при запущенных двух Linux QUEMU host Tinycore и 4 роутерах с прошивкой 3745, загрузка ЦП: 10%, памяти 1.5ГБ. Единственное, проц прыгает при нагрузки типа show run и т.п. а так норм.

      Удалить
  5. в диспетчере видно, как два любых маршрутизатора грузят на 100% два ядра...., при трех - тормоза.
    linux-microcore-2.10 как раз не сильно грузят проц, попробую заменить что-нить....

    ОтветитьУдалить
    Ответы
    1. используйте Tinycore linux и выставьте правильно (*) Idle PC. см. выше

      Удалить
  6. Да, доброй ночи!
    Получилось - снес хосты, загрука 100%, поигрался с Idle PC коммутаторов, когда все три подняты - поменял на каждом из них, в итоге - 20%.
    Вернул хосты и поднял по очереди, во время booting microcore - до 100% на одном ядре, после загрузки - 20%
    , поднял все - общая загрузка 20%, озу 1.2Gb и все работает! Вся схема поднята.
    Как посмотреть какие Idle я выставил?

    ОтветитьУдалить
  7. в настройках коммутаторов нет clock rate для serial почему-то и ....не работает RIP, все прописал правильно, с хостов не пингуются serial на своих коммутаторах....коммутаторы между собой - пингуются.

    ОтветитьУдалить
    Ответы
    1. В настройках RIP для такого уровня лабы (больше и не нужно, потому как RIP, почти нигде, как протокол динамической маршрутизации не используется и дают его обычно для сравнения, что вот EIGRP типа лучше, чем RIP вот в этом, этом, этом и т.д. :) ), а так все предельно просто и делается в три команды:
      router rip
      version 2
      no auto-summary
      network x.x.x.0
      самая главное анонсировать те сети, которые напрямую подключены (directly connect), т.е. куда смотрит наш роутер.
      и не забыть прописать default gateway для хостов и все будет работать!

      Удалить
  8. как отменить команду Router#show ip rip database ?

    ОтветитьУдалить
  9. С первого хоста пингуется 172.16.10.1, не проходит пинг 172.16.20.1(2)
    С R2 пингуется 172.16.10.1 на нет пинга до 172.16.10.10 - в чем ошибка?

    Router(R1)# sh ip route
    ......................
    172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
    R 172.16.50.0/24 [120/2] via 172.16.20.2, 00:00:20, Serial0/0
    R 172.16.40.0/30 [120/1] via 172.16.20.2, 00:00:20, Serial0/0
    R 172.16.30.0/24 [120/1] via 172.16.20.2, 00:00:20, Serial0/0
    C 172.16.20.0/30 is directly connected, Serial0/0
    C 172.16.10.0/24 is directly connected, FastEthernet0/0
    Router#

    ОтветитьУдалить
    Ответы
    1. А с 3-го роутера проходит пинг на 172.16.10.1? Если проходит, то надо смотреть уже на хост, проблема скорее всего в нем...
      Проверь, есть ли на хосте маршрут по умолчанию (0.0.0.0) через роутер.

      Удалить
  10. Добрый вечер!
    да, не было default gateway на хосте, прописал 172.16.10.1 для первого хоста и на др.соответственно.
    Все работает.
    Думаю нужно бы разметить в самом начале пример настройки хоста:
    tc@box:~$ sudo su
    root@box:~$ ifconfig eth0 172.16.10.10 netmask 255.255.255.0 up
    root@box:~$ route add default gw 172.16.10.1
    поправьте, если не так....

    ОтветитьУдалить
  11. Cпасибо большое, все работает! )

    ОтветитьУдалить