Поиск...

понедельник, 6 июня 2011 г.

Настройка OSPF на cisco. Часть 1.

Доброго времени суток!!!


В прошлых постах мы посмотрели, как настраивать протоколы динамической маршрутизации RIP и EIGRP. Сегодня, я предлагаю вам познакомиться с настройками следующего протокола, а именно OSPF. Это, наверное, самый распространенный протокол маршрутизации, используемый в локальных сетях.
Так как он один из самых распространенных, то я предлагаю его рассмотрение разбить на несколько частей. Сегодня рассмотрим базовые настройки.
Итак, добро пожаловать под кат… Часть 1.

Как мы договорились, теорию можно посмотреть в интернете.
Перейдем сразу к настройкам :).
Вот такую схему мы рассмотрим сегодня:



Роутер R1 и R3 у нас являются пограничными маршрутизаторами (ABR) (интерфейсы присутствуют как в магистральной Area 0, так и в обычных Area). Роутер R2 является пограничным маршрутизатором автономной системы (один интерфейс находится в магистральной Area 0, а остальные «принадлежат» другим автономным системам). Роутер R4 является внутренним маршрутизатором (у него все итерфейсы принадлежат одной Area).
В качестве router ID будем использовать Loopback – интерфейсы (точнее их IP – адреса).
Сеть 10.1.0.0/24 будем использовать для «выхода во внешний мир», через нее будет идти default route.
11.0.0.0/8 12.0.0.0/8 13.0.0.0/8 будем использовать для эмуляции «удаленных сетей», в частности, чтобы прописать на них статические маршруты и осуществить их редистрибуцию (redistribute) в OSPF.
Успешной реализацией данной схемы будем считать наличие сетевой доступности между хостами (команда ping), наличие всех маршрутов в таблице маршрутизации каждого роутера (default route, статических маршрутов на удаленные системы и внутренних маршрутов), полученных через OSPF.
Итак, приступим :). Заходим на пограничный роутер (R2) и делаем следующие настройки:
  • R2>en
  • R2#conf t
  • R2(config)#interface loopback 0 – создаем loopback интерфейс
  • R2(config-if)#ip address 192.168.1.1 255.255.255.255 – назначаем ему IP - адрес
  • R2(config-if)#exit
  • R2(config)#interface fa 0/0
  • R2(config-if)#ip address 172.16.1.1 255.255.255.0
  • R2(config-if)#no sh
  • R2(config-if)#exit
  • R2(config)#interface fa 0/1
  • R2(config-if)#ip address 10.1.0.1 255.255.255.0
  • R2(config-if)#no sh
  • R2(config-if)#exit
  • R2(config)#ip route 0.0.0.0 0.0.0.0 10.1.0.2 – добавляем default route
  • R2(config)#ip route 11.0.0.0 255.0.0.0 null 0 – добавляем статический маршрут
  • R2(config)#ip route 12.0.0.0 255.0.0.0 null 0
  • R2(config)#ip route 13.0.0.0 255.0.0.0 null 0
  • R2(config)#router ospf 1 – заходим в настройки OSPF и одновременно запускаем процесс
  • R2(config-router)#network 172.16.1.0 0.0.0.255 area 0 – добавляем все интерфейсы из сети 172.16.1.x в Area 0 (магистральная зона)
  • R2(config-router)#default-information originate – прописываем, что default route будет объявляться всем участникам OSPF этим роутером
  • R2(config-router)#redistribute static subnets – включаем редистрибуцию статических маршрутов в процесс OSPF. Таким образом, об этих маршрутах будут знать все участники процесса OSPF, а не только R2.
  • R2(config-router)#exit
  • R2(config)#exit
  • R2#wr
  • R2#
Посмотрим, что у нас получилось. Выполним команду show run:

 Теперь, перейдем к настройкам роутера R1:
  • R1>en
  • R1#conf t
  • R1(config)#interface loopback 0
  • R1(config-if)#ip address 192.168.2.1 255.255.255.255
  • R1(config-if)#description Router ID
  • R1(config-if)#exit
  • R1(config)#interface fa 0/0
  • R1(config-if)#ip address 172.16.1.2 255.255.255.0
  • R1(config-if)#ip ospf priority 200 – задаем высокий приоритет при выборе выделенного маршрутизатора, то есть этот роутер будет DR.
  • R1(config-if)#no shutdown
  • R1(config-if)#exit
  • R1(config)#interface fa 0/1
  • R1(config-if)#ip address 172.16.51.1 255.255.255.0
  • R1(config-if)#description To_host
  • R1(config-if)#no shutdown
  • R1(config-if)#exit
  • R1(config)#router ospf 1
  • R1(config-router)#network 172.16.1.0 0.0.0.255 area 0
  • *Mar 1 00:04:40.663: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done – свидетельствует о том, что наши роутеры увидели друг друга в процессе OSPF и уже полностью «договорились».
  • R1(config-router)#network 172.16.51.1 0.0.0.0 area 51 – в отличие от прошлой команды, мы добавили в процесс OSPF конкретный интерфейс, имеющий этот IP – адрес. Он относится уже не к магистральной зоне, а к Area 51.
  • R1(config-router)#exit
  • R1(config)#exit
  • R1#wr
Настраиваем роутер R3:
  • R3>en
  • R3#conf t
  • R3(config)#interface loopback 0
  • R3(config-if)#ip address 192.168.3.1 255.255.255.255
  • R3(config-if)#description Router ID
  • R3(config-if)#exit
  • R3(config)#interface fastEthernet 0/0
  • R3(config-if)#ip address 172.16.1.3 255.255.255.0
  • R3(config-if)#ip ospf priority 100 – делаем этот роутер резервным выделенным маршрутизатором (BDR).
  • R3(config-if)#no shutdown
  • R3(config-if)#exit
  • R3(config)#interface serial 0/0
  • R3(config-if)#ip address 172.16.10.5 255.255.255.252
  • R3(config-if)#clock rate 56000
  • R3(config-if)#no shutdown
  • R3(config-if)#exit
  • R3(config)#router ospf 1
  • R3(config-router)#network 172.16.1.0 0.0.0.255 area 0
  • *Mar 1 00:04:44.003: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.2.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
  • *Mar 1 00:04:47.783: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done – наши роутеры увидели друг друга и «договорились».
  • R3(config-router)#network 172.16.10.4 0.0.0.3 area 1
  • R3(config-router)#area 1 stub – эта команда определяет Area 1 как «тупиковая зона». В нее не будут отсылаться некоторые типы LSA (4 и 5) и будет объявляться только default route.
  • R3(config-router)#exit
  • R3(config)#exit
  • R3#wr
Настроим последний роутер R4:
  • R4>en
  • R4#conf t
  • R4(config)#interface loopback 0
  • R4(config-if)#ip address 192.168.4.1 255.255.255.255
  • R4(config-if)#description Router ID
  • R4(config-if)#exit
  • R4(config)#interface fa 0/0
  • R4(config-if)#ip address 172.16.20.1 255.255.255.0
  • R4(config-if)#description To_host
  • R4(config-if)#no shutdown
  • R4(config-if)#exit
  • R4(config)#interface serial 0/0
  • R4(config-if)#ip address 172.16.10.6 255.255.255.252
  • R4(config-if)#no shutdown
  • R4(config-if)#exit
  • R4(config)#router ospf 1
  • R4(config-router)#network 172.16.0.0 0.0.255.255 area 1 – в OSPF Area 1 попадут все интерфейсы, имеющие IP – адреса из сетей 172.16.х.х.
  • R4(config-router)#area 1 stub – также обозначаем нашу зону, как «тупиковую».
  • *Mar 1 00:03:54.239: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.3.1 on Serial0/0 from LOADING to FULL, Loading Done – наш роутер включился в процесс OSPF.
  • R4(config-router)#exit
  • R4(config)#exit
  • R4#wr
Теперь можно проверить все, что мы сделали. Давайте посмотрим на таблицы маршрутизации наших роутеров, посмотрим, что показывают команды группы show и, потом, проверим связь между хостами :).
Таблица маршрутизации роутера R2:


    где:
  • 1 – маршруты, полученные от «соседей» и находящиеся в других зонах (Area 51 и Area 1);
  • 2 – наши статические маршруты в «удаленные сети»;
  • 3 – наш router ID;
  • 4 – статический маршрут по умолчанию (default route).
Таблица маршрутизации роутера R1:


    где:
  • 1 – маршруты, полученные от «соседей» и находящиеся в других зонах (Area 1);
  • 2 – это «внешние» маршруты от других удаленных сетей. Они попали в нашу сеть путем редистрибуции (redistribute) статических маршрутов в OSPF на роутере R2;
  • 3 – наш router ID;
  • 4 – это тоже «внешний» маршрут, но он же является маршрутом по умолчанию (default route). Объявляет его тот же R2.
Таблица маршрутизации роутера R3:


    где:
  • 1 – маршрут, полученный от «соседей» и находящийся в Area 51 (за роутером R1);
  • 2 – маршрут, полученный от соседнего роутера R4, находящегося в той же зоне (Area 1);
  • 3 – «внешние» маршруты от других удаленных сетей;
  • 4 – роутер ID;
  • 5 – маршрут по умолчанию, объявляемый роутером R2
Таблица маршрутизации роутера R4:


    где:
  • 1 – маршруты от «соседей», находящиеся в других зонах (Area 0 и Area 51);
  • 2 – роутер ID;
  • 3 – маршрут по умолчанию. Обратите внимание, что здесь отсутствуют «внешние» маршруты в удаленные сети. Это специфика «тупиковой Area» (stub Area). Сюда объявляется один общий маршрут по умолчанию через ближайшего соседа.
Теперь посмотрим команды show ip ospf и show ip ospf neighbor.
Роутер R2:
Роутер R1:
Роутер R3:
Роутер R4:
Из представленных рисунков видно, что процесс OSPF успешно работает. Выборы DR и BDR прошли так, как мы и планировали, прописав приоритеты на соответствующих роутерах.
Наконец, проверим сетевое взаимодействие между хостами и «внешним» IP – адресом (10.1.0.2).
Хост №1:

    где:
  • 1 – ping на шлюз по умолчанию;
  • 2 – ping на удаленный хост;
  • 3 – ping на «внешний» IP – адрес.
Хост №2:

    где:
  • 1 – ping на шлюз по умолчанию;
  • 2 – ping на удаленный хост;
  • 3 – ping на «внешний» IP – адрес.
Как видно, у нас все получилось. Поздравляю вас!!!
Мы настроили и запустили процесс OSPF с несколькими зонами (Area), сделали редистрибуцию (redistribute) статических маршрутов и маршрута по умолчанию.

На этом я предлагаю закончить этот пост и первую часть :). Надеюсь, вам было интересно и познавательно.
В следующей части попробуем настроить OSPF в NBMA сетях (нешироковещательные сети со множественным доступом (NBMA) (Frame relay)) и настроим это все дело с аутентификацией.
В общем, жду вас с нетерпением, будет интересно :).



Если возникли вопросы, комментарии или еще что то, то смело пишите!!!

С уважением, Ant0ni0n.

27 комментариев:

  1. спасибо, гораздо более понятнее чем на ICND

    ОтветитьУдалить
  2. Спасибо за теплый отзыв!!!
    Надеюсь, будете заходить еще :)

    ОтветитьУдалить
  3. Spasibo bolshoe no u menya est problema.
    Esli ya delayu na R4 "area 1 stub" to poluchayu soobshenie

    Mar 1 00:34:21.563: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.3.1 on Serial0/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
    Esli ya delayu na R4 no area 1 stub togda

    *Mar 1 00:35:28.347: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.3.1 on Serial0/0 from LOADING to FULL, Loading Done

    Pochemu naoborot rabotaet???

    ОтветитьУдалить
    Ответы
    1. moi predidushii komment mogno udalit, vse ok!!!!

      Удалить
    2. Спаибо за оьзыв!!! Так а в чем была проблема, может опишите, другим будет интересно :)

      Удалить
  4. спасибо большое. пиши еще

    ОтветитьУдалить
  5. СПАСИБО!! статья супер!!даже для новичка в этом деле легко догнать!!!
    ПС
    Былобы очень полезно увидеть пост про ip телефонию.И огромная просьба выложить ваш архив ios для gns3(прям всё что есть в 1 архиве)
    ПСС..
    Извеняюсь за назойливость но многим сдесь было бы очень интересно и мегополезно когданибуть увидеть поэтапную настройку для авторизации ppoe pptp.Т.к настройка этого уровня уже....

    ОтветитьУдалить
    Ответы
    1. Спасибо за теплый отзыв!!!
      Насчет выкладывания IOS, напишите мне на почту (во вкладке "Обратная связь" есть координаты), какие именно IOS вам нужны.
      По посту о IP телефонии скажу так, что работа над ним ведется. Он появится в ближайшее время.
      Насчет настройки ppoe и pptp немного не понял просьбы. Не могли бы вы пояснить, чо именно надо описать (настройку конечного оборудования, настройку сетевого оборудования, какой вид аутентификации и так далее...)

      Удалить
  6. Очень понравилось, автору респект

    ОтветитьУдалить
    Ответы
    1. Спасибо!!! Рад что понравилось.
      Заходите еще :)

      Удалить
  7. добрый вечер! у меня пинг между хостами не идет, роутеры видят друг друга а хосты нет! в чем моя ошибка? :))

    ОтветитьУдалить
    Ответы
    1. Добрый день!
      Причин может быть много. Пришлите мне на почту конфигурации роутеров, я гляну.
      А так проверьте, все ли интерфейсы подняты, проверьте настройки сетевых интерфейсов на хостах, видны ли все нужные маршруты и так далее.

      Удалить
  8. Как в кольцевой схеме соединения роутеров выбрать приоритетный маршрут? Правда у меня несколько типов интерфейсов: VPN тунель Fastethernet и frame relay. Игра с приоритетом и костом не увенчалась успехом. Может есть какие-то подводные камни?

    ОтветитьУдалить
  9. здравствуйте! спасибо за пост! настройка в целом понятна, но у меня есть два тупых вопроса. почему зона 1 тупиковая, а 51 нет? и почему маршрутизатор R3 не является магистральным, а R4, соответственно, пограничным?

    ОтветитьУдалить
    Ответы
    1. Добрый день!!!
      По зонам: во-первых, в 51-ой зоне больше нет сетевых устройств, которым можно передавать маршрутную информацию; во-вторых, я просто придумал именно такую схему, чтобы показать больше настроек OSPF :)
      Насчет названия роутеров:
      R3 не является магистральным, так как он является пограничным (имеет интерфейсы в разных AREA);
      R4 не является пограничным, так все его интерфейсы принадлежат одной AREA, которая не является BACKBONE, следовательно он является внутренним :)
      Вот тут можно почитать общую теорию: http://ru.wikipedia.org/wiki/OSPF

      Удалить
  10. Добрый вечер! Во-первых с наступающим Новым Годом!

    Очень полезный сайт, особенно для начинающих. Огромное вам спасибо за труды!
    Вопрос у меня в следующем:
    При настройке маршрутизатора R1 вы опубликовали в OSPF конкретно сетевой интерфейс
    --------------------------
    R1(config-router)#network 172.16.51.1 0.0.0.0 area 51 – в отличие от прошлой команды, мы добавили в процесс OSPF конкретный интерфейс, имеющий этот IP – адрес. Он относится уже не к магистральной зоне, а к Area 51.
    --------------------------

    При такой настройке у меня на всех роутерах в таблице маршрутизации не появляется маршрут в сеть 172.16.51.0/24
    Если же на R1 я публикую целиком сеть
    R1(config-router)#network 172.16.51.0 0.0.0.255 area 51
    то все нормально.
    Собственно вопрос почему вы публикуете конкретный интерфейс ? И какие могут быть причины отсутствия маршрута в таблицах на всех роутерах при публикации именно интерфейса?

    ОтветитьУдалить
    Ответы
    1. Доброго времени суток!!!
      С прошедшими праздниками :)
      Теперь по вашему вопросу... Эту команду я приводил, чтобы показать, что добавлять сети в ospf можно разными способами. Например вам нужно включить ospf только на конкретном интерфейсе (я писал выше другую команду с использованием широкой маски, но тогда в процесс включатся все интерфейсы относящиеся к этой сети и helo пакеты, LSA и так далее будут отправляться в сети за этими интерфейсами. Иногда этого не нужно).
      Насчет почему у вас нет этого маршрута - надо смотреть вашу конфигурацию. Можете ее прислать мне на почту. Будет время гляну.

      Удалить
  11. Спасибо большое!!!!!!!!Все оч. доступно.

    ОтветитьУдалить
  12. Спасибо братиш. Ты адекватен.

    ОтветитьУдалить
  13. Анонимный18 июля 2013 г., 15:35

    Добрый день,
    подскажите, при добавлении в конфигурацию зон(арен) отличных от 0 (т.е добавляем 1 или 51 ) на пограничн.маршрутизаторах, выдается ошибка следующего содержания: " %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 172.16.1.2, FastEthernet0 ". ; не договариваются между собой :((

    конф роутер (R1) :
    router ospf 1
    router-id 192.168.2.1
    log-adjacency-changes
    network 172.16.1.0 0.0.0.255 area 0
    network 172.16.51.1 0.0.0.0 area 51 <--не хочет принимать R3
    и

    конф роутер (R3) :
    router ospf 1
    router-id 192.168.3.1
    log-adjacency-changes
    network 172.16.1.0 0.0.0.255 area 0
    network 172.16.30.0 0.0.0.255 area 1 <--не хочет принимать R1

    ОтветитьУдалить
    Ответы
    1. Добрый день!!!
      Странно, сетевая топология как у меня? Пришлите мне полные конфигурации роутеров на почту.

      Удалить
    2. Анонимный18 июля 2013 г., 17:33

      всё работает, напутал линки когда соединял порты ... сорри..

      Удалить
  14. Доброго времени суток. Респект автору за статью. У меня схема подобная но есть проблема прохождения трафика между хостами, а именно сетевого взаимодействия по порту 445 (smb). Хосты не пускают в шары. Для связи peterbat@mail.ru

    ОтветитьУдалить
    Ответы
    1. Доброго времени суток!!!
      А почему вы думаете, что дело в OSPF? Если сетевая доступность (тот же ping) присутствует, то тут дело уже в security (access-lists, фаервол и т.д.) мне кажется...

      Удалить
  15. Добрый день! Пытаюсь всё собрать в Packet Tracer работающую схему. Опять не получатся. Внутренний маршрутизатор R4 не хочет поднимать OSPF. Помогите пожалуйста найти ошибку...

    ОтветитьУдалить
  16. На R4 с какой целью применили Lo0 с адресом 192.168.4.1/32 ? В широковещательный домен кажись не попадает

    ОтветитьУдалить